Monday, July 26, 2010

Makerbot RS485 ~ Extruder board: Null version reported! BUG mismatch ? ;-(

Having had a really Good experience with ReplicatorG18...
Generated a fair amount of Gcode to try on my MakerBot build..

I flashed my Sanguino / Mother Board V1.1 with the 1.6 version of the Makerbot SW.
works great until I try to run any steppers from my nice new Gcode. Boards light leds flash chips get warm motors stay stationary. Solution was edit the config file and change the line.

#define STEP_DELAY 175  // usual value is 1..?????

I cant think why I need to do this though usually this is delay is 1-2 uS

I came across this unwelcome error Message next when starting ReplicatorG you gt a Jar file mismatch warning on the rxtx lib and Dll. Visiting the site there is a warning saying this:-

"The 2.2pre2 bins contain the 2.2pre1 jar file and the 2.2pre2 native lib which causes a mismatch warning."

It is only a warning but playing it safe I installed the stable version


"Use newer binary version such as rxtx 2.1-7r2 (stable), which does work on Windows."

Next I then came across this problem of  "Extruder board: Null version reported!" going through over 85 threads in MakerBot Operators google group took some time as the threads were quite heavily replied to.

Provided little help as I have already tried every thing suggested to fix the problem.

Do any of you run the Makerbot firmware if so which hardware do you have brd versions.
I have two Motherboard V1.1 both work as Sanguino mother boards except maybe the RS485 interface is not working maybe... I have 4 built and working Extruder V2.1 extruder controllers all working except maybe the RS485 interface. Any Ideas on what I might be missing that is staring me in the face.


Firmware versions tried.
ASC 1.4,1.5,1.6,1.8HP,1.8 with SM 1.4,1.5 & 1.6
and the V2 Firmware MB-rrmbv12-V2 range used with the matching EC-ecv22-V2 range.
I have tried a little mixing and matching of versions but by no means all of the possible combinations.

Has any one else seen these problems??

1/. Having the need to increase the stepper delay by 175% to get steppers to work?
     Any ideas on what is going on why would my V2.3 Stepper boards or stepper motors need a longer step pulse to work? Nb I have seven working V2.3 stepper controller boards all fail with the 1-2uS delay.

2/. Is there a combination of Firmware that works if you have the V1.1 MB with V2.1 Extruder controllers?
   
     Both the MB and the EC boards work as Processors Controlling every thing else it only appears to be the R3485. I have used the latest boot loaders on both boards They flash every time with no problems.

From my look at the Hardware there is very little difference between the various versions of the MB and EC boards things like the reset switch ~ I rearranged the tracks to solve the PCB problem.

The whole set up is running from a 4A bench power supply max current hits 2A with all steppers running
Thus eliminating any switch mode noise as the PSUs are transformer type with internal CPU for voltage and current control.
Post a Comment